# New ports collection makefile for:	ispdb-monitor-sw-s3600-52p-si
# Date created:				2007 May 12
# Whom:					GD <gd@pikenet.ru>
#
# $FreeBSD$
# $Id: Makefile,v 1.8 2013/10/14 16:49:35 babolo Exp $

PORTNAME=	ispdb-monitor-sw-s3600-52p-si
PORTVERSION=	0.03
CATEGORIES=	ispms russian
MASTER_SITES=	http://www.ispdb.ru/
DIST_SUBDIR=	ispms

MAINTAINER=	gd@pikenet.ru
COMMENT=	ISPDB submodule of monitoring module - part of ISP Management System

BUILD_DEPENDS=	${LOCALBASE}/libexec/ispms/include/ispdb.VERSION:${PORTSDIR}/ispms/ispdb\
		${LOCALBASE}/libexec/ispms/include/ispdb-www.VERSION:${PORTSDIR}/ispms/ispdb-www\
		gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS=	${LOCALBASE}/libexec/ispms/include/ispdb.VERSION:${PORTSDIR}/ispms/ispdb\
		${LOCALBASE}/libexec/ispms/include/ispdb-www.VERSION:${PORTSDIR}/ispms/ispdb-www\
		${LOCALBASE}/libexec/ispms/include/ispdb-monitor.VERSION:${PORTSDIR}/ispms/ispdb-monitor\
		${LOCALBASE}/share/postgresql/contrib/pglib_bit.sql:${PORTSDIR}/databases/babolo-pglib\
		psql:${PORTSDIR}/databases/postgresql84-client\
		pgoblin:${PORTSDIR}/databases/pgoblin\

WITHOUT_LOCAL_PATCHDIR=yes
#MAN1=
#MANLANG=	ru_RU.KOI8-R
#MANCOMPRESSED=	yes
NO_STAGE=	yes

.include <bsd.port.pre.mk>

.if exists(${LOCALBASE}/etc/babolomake.conf)
. include <${LOCALBASE}/etc/babolomake.conf>
.endif

.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
. if !defined(MASTER_SITES_ISPMS)
IGNORE=		"mail to noc@pikenet.ru for sources."
. else
MASTER_SITES=	${MASTER_SITES_ISPMS}
. endif
.endif

.include <bsd.port.post.mk>